ExPVR V3.1

Announcements about ExPVR, the Sky+ HD and XTV recording extractor.
mrmt32
Site Admin
Posts: 585
Joined: Mon Jul 25, 2011 1:05 am

ExPVR V3.1

Postby mrmt32 » Thu Jan 26, 2012 9:48 pm

ExPVR V3.1 brings a new recording preview feature. This allows you to view recordings from your planner without having to first extract them. You can find the new version at http://www.ph-mb.com/products/ExPVR/downloads.

andyf
Posts: 5
Joined: Fri Feb 03, 2012 1:13 pm

Re: ExPVR V3.1

Postby andyf » Fri Feb 03, 2012 1:16 pm

I just tried using this to format a 2TB drive for a DRX890 but I could find a way of just formatting the drive like was possible to do in version 2. Is there a way or will I have to use version 2?

mrmt32
Site Admin
Posts: 585
Joined: Mon Jul 25, 2011 1:05 am

Re: ExPVR V3.1

Postby mrmt32 » Fri Feb 03, 2012 7:31 pm

The format only feature has not yet been implemented in the new version (I will put it back in soon), in the mean time version 2 will allow you to do this (http://www.ph-mb.com/downloads/ExPVR/ExPVR_2.1.7.rar).

andyf
Posts: 5
Joined: Fri Feb 03, 2012 1:13 pm

Re: ExPVR V3.1

Postby andyf » Sat Feb 04, 2012 1:33 am

Thanks for the quick response.

I did it today with V2.1.3 which I downloaded last October - is that OK?

The only reason I ask is that when I put the new 2TB in the DRX890 (without a viewing card) it appeared to be OK and booted up and allowed me to view some "freeview" programmes etc. but obviously it woldn't let me record (and a few other things) without a "bonded" viewing card. With the viewing card "bonded" to my other DRX895 put in it the DRX890 it would let me record (apparently), but when I tried to watch the recording from the start (whilst it was still recording) it just hung. I'm now wondering if this is because of:
a) "formatting" with v2.1.3;
b) the DRX890 being confused by my WD20EARS which has "Advanced Format";
c) what I tried just won't work unless the box has a properly "bonded" viewing card.

Is it "safer" to create the new bigger HDD from an existing HDD with recordings on it with your later version?

Thanks

Databits
Posts: 1
Joined: Sat Feb 04, 2012 6:16 pm

Re: ExPVR V3.1

Postby Databits » Sat Feb 04, 2012 6:36 pm

Hello. It is not possible to view a recording from a non bonded card on the 890 / 895 boxes. I think thats why it hung. It will record the program but until you pair the card it will not play, just comes up with an error, "Playback interupted" Tried it myself and it will not work untill you pair the card to the box.
It was possible with the older Thomson 8215 boxes. But the new R**.***.**.** operating system will not play back a scrambled recording unless it matches the decode in the card and the serial number and model number in the box.

As to the AF 4k sectors on your WD drive I would like to know if that works myself, so If you pair the card to the box using the phone line or CS at sky then try to play back a recording and it still locks up it is the AF 4k problem.

Look forward to hearing how you get on.
Hope that helps.

andyf
Posts: 5
Joined: Fri Feb 03, 2012 1:13 pm

Re: ExPVR V3.1

Postby andyf » Mon Feb 06, 2012 4:55 pm

Thanks

So in theory I was OK using version 2.1.3, instead of the 2.1.7 that you posted in reply to my 1st question?

I've seen posts in other forums suggesting the WD20EARS works OK but there has never been any mention of using the jumper or not

mrmt32
Site Admin
Posts: 585
Joined: Mon Jul 25, 2011 1:05 am

Re: ExPVR V3.1

Postby mrmt32 » Tue Feb 07, 2012 12:28 am

As far as I remember, 2.1.7 has no changes relating to disk copying over 2.1.3 (it just had a few fixes for recording extraction) so it shouldn't make any difference which one you used.

It is hard to say what is causing the problem, it could well be due to the unpaired card but I have no way of testing it. Copying from another disk with the new version would be more likely to work as it will ensure that the databases are of the exact same version (for the format option ExPVR generates the databases from scratch, and there is a slight possibility that Sky have changed them for some boxes). Copying the recordings from another drive will also copy the databases 'as is'.

People seem to have used AF drives successfully (as you say, the WD20EARS seems to be quite popular and I have heard of no issues with it). The trouble with advanced format drives is that their performance is hampered slightly if they are not accessed in 4kb blocks (as opposed to the 512 bytes of old drives). The FAT32 file system is not designed to be aligned so this happens, also the start of the partition will normally lie just before the end of the first 4k block (setting the jumper will fix this, but not the problem with the FAT32 clusters not being aligned). Whether or not this causes problems with a sky box depends on how severe the performance drop is; as people seem to have been using AF drives without any trouble I would like to say that it is not bad enough to cause any problems.

andyf
Posts: 5
Joined: Fri Feb 03, 2012 1:13 pm

Re: ExPVR V3.1

Postby andyf » Tue Feb 07, 2012 10:54 am

Thanks

My dilemma is that until I "pair" the card I don't think (but must admit haven't tested) that I can get a recording onto the original DRX890 drive and so cannot use v3.1 of EXPVR, as from what I can see it needs at least 1 recording to allow a drive copy from the original HDD to new bigger 2TB HDD.

Maybe I need to wait until the Format and Copy feature is back in v3.1, but just wondering how easy is it to make the existing code "copy" an empty drive without any recordings?

In the meantime I'll put the original HDD back in the DRX890 and see if I can get a recording on to it so that I can then use V3.1 to copy to the new 2TB drive (and al also be able to check if the playback "hang" is also there on the original drive.

andyf
Posts: 5
Joined: Fri Feb 03, 2012 1:13 pm

Re: ExPVR V3.1

Postby andyf » Tue Feb 07, 2012 7:09 pm

Today I put the original 500GB drive back into the DRX890 and it appears I can report success.

1 - Returned original 500GB HDD to DRX890
2 - Connected up and booted up OK.
3 - With an "unpaired" viewing card (from my DRX895) I was able to record and playback (!), though it appears only SD channels - HD ones went into the planner but didn't start recording.
4 - Removed HDD and copied the recordings to the new 2TB WD20EARS (after removing the partition) with the latest PVR v3.1
5 - New 2TB HDD put into DRX890
6 - Connected up and booted up OK.
7 - Still with the "unpaired" viewing card as above I was able to playback the copied recordings AND also record and playback a third. No "hanging" symptoms seen as reported previously so perhaps it is safer to copy an existing HDD with v3.1 rather than just a format with v2.1.

Admittedly this isn't an exhaustive test but it's looking promising.


Return to “Announcements”

Who is online

Users browsing this forum: No registered users and 1 guest