[Resolved] ExPVR 3.7 shows no recordings but v3.1 is OK

Post here if you have any problems with ExPVR.
mrmt32
Site Admin
Posts: 585
Joined: Mon Jul 25, 2011 1:05 am

Re: ExPVR 3.7 shows no recordings but v3.1 is OK

Postby mrmt32 » Tue Jan 15, 2013 2:27 pm

Thanks for all the testing, there should not really be any difference between running in windows 8 and 7, but some small thing must be causing issues. It seems that the loading window is just not being put up which is in turn causing other issues, I will either find a windows 7 pc or do a install on a virtual machine tonight and work out what is causing it.

hcblue
Posts: 6
Joined: Tue Jan 15, 2013 9:40 am

Re: ExPVR 3.7 shows no recordings but v3.1 is OK

Postby hcblue » Tue Jan 15, 2013 2:48 pm

No thanks needed for "the testing". Just happens that your new release coincided with my new HD box to replace the old SD box.

Copy is now in progress on Win8 (only 2 hours to go!) so fingers crossed and thanks for some excellent software (I will donate once it's worked!!)

Paul

mrmt32
Site Admin
Posts: 585
Joined: Mon Jul 25, 2011 1:05 am

Re: ExPVR 3.7 shows no recordings but v3.1 is OK

Postby mrmt32 » Tue Jan 15, 2013 6:43 pm

I have just tested 3.7 on a windows 7 PC and it appears to work fine. Do you know what version of the .NET framework was installed on your windows 7 pc? It should be listed in 'Programs and Features'.

mrmt32
Site Admin
Posts: 585
Joined: Mon Jul 25, 2011 1:05 am

Re: ExPVR 3.7 shows no recordings but v3.1 is OK

Postby mrmt32 » Tue Jan 15, 2013 7:10 pm

Ok, some time on google has found this: http://social.msdn.microsoft.com/Forums ... 8b622a7e4a. It seems that version 4.5 of the .NET framework replaces version 4.0 (unlike all previous versions which are installed along side other versions for compatibility reasons). As windows 8 ships with 4.5, when developing / debugging software on a windows 8 computer (or windows 7 that has been updated to 4.5) the software will use the V4.5 libraries EVEN if it targets 4.0 (which ExPVR does as 4.5 is not available on XP). This does not seem to bad, but there are quite a few bug fixes in V4.5, meaning that if one of these bugs in .NET affects the running software (which it appears to be doing) it will not show up on any computer which has V4.5 installed.

I am guessing there is some bug in WPF (the user interface part of .NET) which is causing the loading dialogue to not show on computers with V4.0 installed. I will have to install a clean windows 7 in a virtual machine without an updated .NET framework and try and identify what is going on. I really do not know why Microsoft have released the update in this way, as it makes it far harder to target older operating systems (XP) and gives unreliable results when not everyone has necessarily updated to V4.5. Setting ExPVR to target V4.5 would fix this as it would force users to update, but then all Windows XP users would not be able to use ExPVR.

Basically, for now, if you are not running windows XP, updating the .NET framework to V4.5 will fix this issue. For windows XP users I will need to find out what bug in 4.0 is causing this problem and try and work round it.

hcblue
Posts: 6
Joined: Tue Jan 15, 2013 9:40 am

Re: ExPVR 3.7 shows no recordings but v3.1 is OK

Postby hcblue » Tue Jan 15, 2013 8:16 pm

Excellent diagnostics - my Windows 7 PC is on v4 of .Net so that seems to be the solution.

Thanks for all your help

Paul

bondsc
Posts: 7
Joined: Mon Jan 14, 2013 10:31 pm

Re: ExPVR 3.7 shows no recordings but v3.1 is OK

Postby bondsc » Tue Jan 15, 2013 8:50 pm

I just installed .NET Framework 4.5 on the Vista PC (I've been keeping the PC up-to-date with Windows update, but .NET 4.5 doesn't seem to get offered via WU).
It's immediately fixed the problem. I can open the diagnostic .ZIP file and see the recordings inside.

When I take the HDD out of the Sky+HD box again, I'll re-test ExPVR 3.7 with the .NET 4.5 update on the disk for real, but I'm certain it will be fine.

Thanks for the assistance.

Simon


Return to “Help & Support”

Who is online

Users browsing this forum: No registered users and 1 guest